PS4 News on Facebook! PS4 News on Twitter! PS4 News on YouTube! PS4 News RSS Feed!

  1. #1

    PS2 no AV?

    Ok guys,

    let me give you my background ive modded for along time PC's bout 5-6 xbox's 3-4 360's and i got my buddys PS2. he wanted a green translucent case and 2 4' cathodes. i though easy enough its all 'plug and play' no super large parts of modding and i got it all in eventually.

    the lights are working and the system is turning on and looking like it works but theres is no longer Audio or Video and ive completly unsoldered the lights and im still not getting AV but the front lights work and the laser looks for a disc, what did i do or not do (i lost 2 screws but they arnt grinding anything are they? :??

  2. #2
    Join Date
    Apr 2005
    Hmm..sounds like some plug or ribbon cable isn't in secure or not even plugged in, is the reset/eject button ribbon alright as this is a very fragile ribbon cable and can be damaged very easy.

    Besides that i am not sure unless something was crossed and shorted something, sometimes if you just unplug everything again and re-insert plugs and ribbon cable it might work as i had this happen to me a few times, seems kinda strange but it has worked at times.

    And welcome slayer466 to PS3NEWS.COM
    Last edited by Starlight; 06-19-2007 at 11:05 PM

  3. #3
    ummm the only ribbons i unplugged was the one that goes to the controller ports on this version the power/eject is connected to the box not the lid, and what ribbons should i check cuz theres alot (this is why i hate my ps2 and love my xbox, screw ribbons)

  4. #4
    Join Date
    Apr 2005
    Didn't know that you never touched the reset/eject ribbon cable as you didn't specify which version ps2 it was, then i am assuming it is a v9 or v10 ps2.

    Now if you just unplugged the controller ribbon cable then it should by rights work, did you solder anything in this ps2?

  5. #5
    yes i did, and im not an idiot (not saying u called me one or assumed it) so i can understand pretty much any language of computers u throw at me and sorry i did not check the version, but yes i did i soldered cathodes to the 12V and neg on the bottom of the PSU they are no longer soldered there or anywhere.

    the only thing is is i connected the pos. wire to the neg on the psu and the neg to pos frying my inverter, but that wouldent have harmed the PS2 would it? but the PSU works, cuz its lighting the lights when soldered and turning every thing on...

  6. #6
    Join Date
    Apr 2005
    Never said you were and i would never say a thing or think a thing like that about any member....ps2's are very touchy when you solder in them and by what you described in your post above there might have been a chance something got fried, the only thing i can suggest is to start checking the fuses on the motherboard as there are a few of them and pics of the motherboard with the location of these fuses can be obtained in the Sticky thread in this forum.

    Sorry that i haven't got more info at this time, but a fuse might have been blown, these fuses are very small in size but will have to be checked.
    Last edited by Starlight; 06-20-2007 at 12:23 AM

  7. #7
    ok i finally got around to getting the thing open and lookin at the fuses and none seem to be damaged or burnt what do you guys suggest now?

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts